Welcome, Guest. Please login or register.

Username: Password:

Author Topic: Connect Error: Timeout  (Read 631 times)

PaulEvans

  • Full Member
  • ***
  • Posts: 11
    • View Profile
Connect Error: Timeout
« on: June 22, 2018, 10:38:40 »

Hi. I have an AstroEQ purchased in late 2014, linked to a Lenovo X201 laptop running CdC, Astrotortilla and PHD2, along with software to control my DSLR. Mount is an EQ5 with belt drive.
I use a USB hub to connect the AstroEQ and the DSLR to one USB port. The guidecam uses a separate lead to a different USB port - ZWO guidecams don’t like USB hubs. Laptop is running Win 10/64, all software and firmware is latest versions. This has all been working fine, and is incredibly useful.
Last night for some weird reason I started getting EQASCOM “Connect Error: Timeout” messages, i.e. neither CdC nor the EQASCOM toolbox would connect to the AstroEQ, and hence the mount. The camera control software would happily talk to the DSLR using the same USB port and USB hub.
The AstroEQ config utility can see and talk to the AstroEQ. I tried swapping USB cables and even took the USB hub completely out of the chain by plugging the short USB lead from the AstroEQ directly into the laptop - made no difference.
I was using the Device Manager ports list, to make sure I had the correct port specified in the EQASCOM toolbox. Interestingly the little binoculars button in EQASCOM toolbox never found the port I’d set, despite Windows Device Manager not showing any errors or warnings against that port. I even cleared out old USB generic hubs and unused USB port entries from device manager, but it wasn’t using ports over 16 anyway.
I’m wondering if I’ve had a recent Windows 10 update, and whether it has “broken” something in the USB stack on my laptop. Any other ideas and suggestions would be gratefully received.

Paul
Logged

PaulEvans

  • Full Member
  • ***
  • Posts: 11
    • View Profile
Re: Connect Error: Timeout
« Reply #1 on: June 22, 2018, 16:15:39 »

Further info - when I plug in the USB lead from the hub (and hence AstroEQ and DSLR) to the laptop, and look at properties of the USB Serial Port via Device Manager, under the events tab, it installs the Windows usbser.sys driver which has a result code 0, and then attempts to load the AstroEQ driver mchpcdc.inf, which fails with error code 0x0. So that'll be why its not working then....but why has that suddenly started happening? It happens exactly the same whether I plug the AstroEQ directly into the laptop or via the USB hub, so the hub is not a factor. At least I know where to look now...

Edit - and when I said above that AstroEQ config could talk to AstroEQ, it looked like it was - but actually it can't....

Edit 2. I found the link on this site which says that I don't need the AstroEQ driver under Windows 10, because the one supplied with Windows 10 (usbser.sys) works fine by itself. I also think I know why the system is trying to load the AstroEQ driver - it is because the property "included infs" for the USB Serial Port is set to "mdmcpc.inf", i.e. the inf for the AstroEQ driver. What I am currently trying to find out (with little success, despite much googling) is how and where "included infs" might be set, and more specifically, how to unset it!

Edit 3. After last update, Tom came up with the news about issues caused by EQMOD v2.00. As I have EQMOD 2.00K you can guess the rest. Downloaded new config utility, allowed me to connect to AstroEQ, installed new firmware, detected and fixed corrupt EEPROM, re-entered my config, and laptop and AstroEQ now seem best friends again. Now to load up the mount, connect everything in live configuration, and make it sure normal service has been restored. Tom, thanks very much for detecting and fixing this so quickly.

Paul
« Last Edit: June 24, 2018, 09:08:20 by PaulEvans »
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 739
    • View Profile
    • AstroEQ
Re: Connect Error: Timeout
« Reply #2 on: June 24, 2018, 22:55:15 »

Glad to see it fixed your problem.

I was sort of caught off-guard with this one. I haven't been keeping track of changes in EQMOD until somebody on Github raised the issue.

Not entirely sure why it was causing issues with USB detection. Having said that, "Error code 0x0" is pretty universally indicative of "success". So my guess is that it wasn't so much a USB detection issue as it was a comms issue.
Logged
Tom Carpenter (AstroEQ)

PaulEvans

  • Full Member
  • ***
  • Posts: 11
    • View Profile
Re: Connect Error: Timeout
« Reply #3 on: June 25, 2018, 10:10:07 »

And just some final tidying up, may include some useful hints for others. Ran for 30 mins last night and then the dreaded "comms error - timeout" popped up again. "Don't panic Captain Mainwaring". I'd not rebooted the laptop since upgrading the AstroEQ firmware and fixing the EEPROM corruption.

The following may be helpful for others with a similar issue. If you unplug the USB lead from the AstroEQ, the USB serial port disappears from Device Manager. However, if you then in Device Manager click "view / show hidden devices", it will show N (5-6 in my case) “greyed out” instances of earlier USB Serial Ports not in use, right click on each offers you choices including “uninstall driver” and “uninstall device”. Went for "uninstall device", when deleting the first instance (but not the others) windows offered me the choice to also uninstall the driver. Said yes to both, and deleted all previous "greyed out" USB serial port device instances and their associated drivers.

Then and only then, rebooted the laptop, and when windows restarted and after logging in, plugged in the cable from the AstroEQ  - got a windows popup bottom RH corner “setting up a device - setting up AstroEQ mount controller” followed by a second popup saying “COM4 was ready to go”. So this is a completely clean install of the drivers.

I find it really useful (and a good check for whether things are likely to work well) to use the "binoculars" port search tool in EQASCOM toolbox, to find the AstroEQ com port. Finds COM4 OK. Mount behaved perfectly for next 2 hours, which is more than I can say for my noob attempts at guiding :-)
Logged