Welcome, Guest. Please login or register.

Username: Password:
Pages: 1 [2] 3

Author Topic: Slewing Goto problems  (Read 11462 times)

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #15 on: December 01, 2016, 00:34:11 »

Hi, I've updated the firmware, changed the connectors, swapped the motors and tried a different power supply. Unfortunately I'm still having the problem of the east overrunning. I've discovered if I click just once on the east button, the overrunning doesn't occur, it only happens when I hold the button down.

You mentioned in an earlier post that it might be a comms issue. Would changing my comm port help? Any help would be greatly appreciated.
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 739
    • View Profile
    • AstroEQ
Re: Slewing Goto problems
« Reply #16 on: December 06, 2016, 19:00:19 »

HI,

Sorry for the delay in responding, it's been a hectic weekend getting the next batch of AstroEQs ready.

I don't think that changing the com port will help.

I'm really not sure what the issue is as I haven't been able to recreate it.

I have some steps for you which will help me try to identify the issue if that is ok.

From here if you could download the files called "SerialEcho.exe" and "com0com-###.exe" (if you have a 64bit OS, get the "x64" one, for a 32bit OS, get the "x86" one).

If you install com0com by following this video (you only need to watch from 0:45 to 1:20 ish). That will set up a virtual serial port pair which if you look in device manager, you should a device group called "com0com - serial port emulators" inside which there is something called "com0com - bus for serial port pair emulator 0 (COM# <-> COM#)". The two COM# will tell you which com port numbers are used by com0com.

Next, open SerialEcho.exe. You should see two boxes on the screen, one at the top, one at the bottom. Above each is a dropdown menu that says "SELECT COM PORT".

In the bottom menu, select the com port number of the AstroEQ. In the top menu, select one of the com0com port numbers (it doesn't matter which one).

Now set the COM port for EQMOD to be the other com0com port (the one you didn't select in the SerialEcho wizard).

Then open EQMOD as you would normally. EQMOD should connect fine. If it doesn't, double check you have selected the correct com ports.

In the SerialEcho screen, you should now see data going back and forth between the AstroEQ and EQMOD.

If you have any problems following the instructions and getting this far, let me know.

Otherwise, run a couple of tests with the buttons. First by clicking just once on the east button, then wait for the motor to stop. Next hold the button down so that it starts overrunning. After a couple of seconds, press the stop button in EQMOD so that the motors stop running. Finally, once they stop running again, go to the SerialEcho window and press 'q' on the keyboard. SerialEcho should quit (EQMOD might crash at this point, but it doesn't matter).

You should find two log files, "C:\TEMP\AstroEQLower.log" and "C:\TEMP\AstroEQUpper.log". If you could upload those to the forum for me to take a look at.


Kind Regards,
Tom.
Logged
Tom Carpenter (AstroEQ)

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #17 on: December 08, 2016, 11:27:58 »

Hi, thanks for the reply, I'll sort that out and upload it next week.
Logged

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #18 on: February 01, 2017, 10:05:12 »

Hi, Apologies for the long delay. I had all my astro stuff packed away over the christmas period and I've just got around to doing this.

I followed your instructions but unfortunately the new ports don't show up in serialecho. Also the numbers for the port only show up in device manager if I go into setup and tick 'emulate baud rate'. The port numbers are CNCA0 and CNCB0.

I downloaded the x64 com0com but it installed into the x86 program folder by default and also I didn't get the windows update popup as shown in the video, I went into the device manager and updated 'bus for serial port emulator' manually.

The two serial port emulators will not update, and in the properties under events is the message 'Device com0com\port\CNCA0 requires further installation.'

I'm running Windows 10 if that makes any difference. Thanks for your help.
Logged

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #19 on: February 01, 2017, 10:18:13 »

Think I might know what the problem is. When I'm trying to install the x64 version of com0com the option COM# <-> COM# doesn't appear so I can't tick it. After reviewing the video I made the mistake of leaving the paired ports option ticked, but the other option doesn't appear in the installation menu.
Logged

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #20 on: February 01, 2017, 10:29:45 »

Just checked the x86 install has the COM# <-> COM# in the components section but the x64 doesn't. I'm running an x64 system so I'm at a bit of a loss.
Logged

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #21 on: February 01, 2017, 11:19:05 »

Phew. Managed to sort it I think. I installed a more recent version of com0com and disabled digital driver signing. I was still getting error messages when installing but my com ports appeared after manually installing the drivers. I did as you asked and tapped once east and then held down east after a pause.

EQMOD was on it's lowest speed setting of 4, I don't know if this makes a difference. Let me know and I'll redo the test if needs be. The requested logs are attached. Thanks again for your help.
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 739
    • View Profile
    • AstroEQ
Re: Slewing Goto problems
« Reply #22 on: February 01, 2017, 20:32:50 »

Did the overrun occur during those tests?
Logged
Tom Carpenter (AstroEQ)

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #23 on: February 02, 2017, 16:46:55 »

Hi, I wasn't using it outside so I wasn't able to tell. The over run does always occur though when I hold down the east slew in eqmod, so I'd go off the assumption that it was. I've never known it not to happen.

It's more noticible at high magnifications.

I did the single east button press first and then held it down after a short pause 20 seconds or so.
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 739
    • View Profile
    • AstroEQ
Re: Slewing Goto problems
« Reply #24 on: February 02, 2017, 18:29:43 »

It's clear from the trace that you have sent that the AstroEQ is not doing anything untoward.

I've just noticed the video you posted in August which I completely missed, and from that I can tell that what you are seeing is not so much overrun as it is the acceleration/deceleration of the mount. When going at speeds greater than 2x, the mount accelerates and decelerates which is why it appears to slow down to a stop, and why it feels like it takes a moment to respond to any motion. To avoid this you should do any final manual correction at 2x speed or lower as it should react immediately (aside from any backlash in the mount).

I've been trying to improve the acceleration/deceleration routines over the last few versions, but it's not particularly easy as to get a linear acceleration I need to change the pulse rate with a reciprocal relationship which is time consuming on the processor to calculate (at the moment I try to approximate it without doing any time consuming division).
Logged
Tom Carpenter (AstroEQ)

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #25 on: February 02, 2017, 18:48:37 »

Ok thanks, it just seems weird that it only ever happens in one direction though, but it's not a deal breaker, just a bit annoying sometimes.
Logged

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #26 on: February 02, 2017, 19:04:48 »

This is another video I've done since, it illustrates it a bit better:

https://www.youtube.com/watch?v=ZjsChCEMlNE&feature=youtu.be

In the vid I slew west first and the star shows the normal decelleration and stop. Then I slew east and the same thing happens, but then the star slowly continues drifting east for about 5-10 seconds when it should of stopped.
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 739
    • View Profile
    • AstroEQ
Re: Slewing Goto problems
« Reply #27 on: February 02, 2017, 22:18:54 »

Hmm, that's more interesting. It almost seems like it is either taking EQMOD a while to tell it to start tracking again, or the AstroEQ is taking a while to respond.

I can't see anything in the log you attached to suggest either. From the data, I presume that you didn't have sidereal tracking enabled when you ran the tests? Would you be able to collect another set of data but with sidereal tracking enabled while you are trying to do the movements?
Logged
Tom Carpenter (AstroEQ)

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #28 on: February 02, 2017, 23:49:54 »

Hi, thats right the tracking wasn't enabled. I'll redo the test with the tracking enabled for you.
Logged

cuivenion

  • Sr. Member
  • ****
  • Posts: 73
    • View Profile
Re: Slewing Goto problems
« Reply #29 on: February 03, 2017, 09:59:45 »

Hi, please find attached the new logs. Here's what I did in order:

- Opened and setup Serialecho
- Started EQMOD
- Unparked mount
- Started Sidereal Tracking
- Set Slew speed to 64
- Tapped once on East
- Waited about 20 seconds
- Held down East for about 10 seconds
- Waited about 20 seconds
- Pressed Stop button in the slew controls
- Quit Serialecho

Thanks again!
Logged
Pages: 1 [2] 3