Welcome, Guest. Please login or register.

Username: Password:
Pages: 1 2 [3] 4 5 ... 10

Author Topic: [Completed] AstroEQ 8.0.3(beta)  (Read 56870 times)

jukkapaavilainen

  • Full Member
  • ***
  • Posts: 10
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #30 on: September 13, 2016, 17:20:33 »

Hello. I'am new in here. I have weird motor problem and was curious should i try to use the beta firmware? Is this working properly.

Will do longer post about my problem when I have time.
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 780
    • View Profile
    • AstroEQ
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #31 on: February 05, 2017, 22:24:54 »

Wow it's been a long time since I started trying to write the 7.5.0 firmware. In the mean time I've finished one job, moved country, started a new job and also started a PhD.

Anyway, I've finally found some time to work on the new firmware. Updates will include:

  • Ability to disable "gear change" - i.e. where the AstroEQ changes microstepping mode to achieve higher torque. For some people this causes nasty vibrations in the motor
  • Brand new motor routines - accel/decel is now done using lookup tables so a linear ramp is now possible. The code is also now converted back to C from asm for better portability
  • Code has been massively tidied up with improved formatting and commenting for anyone wishing to make mods
  • New programming commands added to allow configuration of new accel tables
  • Further development of the planned hand controller interface which should bring at the very least basic NESW + low speed/high speed controls when not connected to PC

I haven't yet commited the changes to Github, but will do in the not to distant future.

I also didn't have the time this weekend to update the config utility to generate the accel/decel tables so the firmware changes can't yet be used. I will try to find time next weekend to get a beta version ready for people to test.
Logged
Tom Carpenter (AstroEQ)

TCWORLD

  • Administrator
  • *****
  • Posts: 780
    • View Profile
    • AstroEQ
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #32 on: February 08, 2017, 00:20:45 »

Well I've managed to finish updating the config utility to generate the new acceleration tables and configure.

I'll package it all up tomorrow and release the new beta.
Logged
Tom Carpenter (AstroEQ)

TCWORLD

  • Administrator
  • *****
  • Posts: 780
    • View Profile
    • AstroEQ
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #33 on: February 08, 2017, 18:04:25 »

New beta released (attached to the original post).

I would be grateful for volunteers to test it out and report back any issues faced.
Logged
Tom Carpenter (AstroEQ)

Smokie

  • Full Member
  • ***
  • Posts: 39
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #34 on: February 08, 2017, 21:00:48 »

hello Tom

willspend time on it tomorrow

gr Henk
« Last Edit: February 08, 2017, 21:05:48 by Smokie »
Logged

Jonesdee

  • Full Member
  • ***
  • Posts: 26
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #35 on: February 08, 2017, 21:16:31 »

Hi Tom

I will try it with DRV8825 drivers tomorrow and let you know.

Cheers

Dave
Logged

almcl

  • Full Member
  • ***
  • Posts: 26
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #36 on: February 09, 2017, 11:31:15 »

Tom

Tried it briefly this morning (haven't used the EQ5 mount for a while so getting connected took a little thought).

First attempt reported EPROM blank or corrupt.  Subsequent attempts it reports Read Failed! Connection Unavailable.

I confirmed with version 7.4 that neither message is correct: the EPROM is still loaded and the connection still works.

Machine is an elderly Lenovo Thinkpad X61s running Windows XP pro.  This happened with both the .exe files.

Screen capture of the cmd window attached.

 
« Last Edit: February 09, 2017, 11:45:18 by almcl »
Logged

Smokie

  • Full Member
  • ***
  • Posts: 39
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #37 on: February 09, 2017, 11:44:32 »

Hello Tom,
i am getting a message Failled to calculate accelleration Table,cannot cont

gr,Henk
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 780
    • View Profile
    • AstroEQ
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #38 on: February 09, 2017, 12:05:57 »

Well that's a good start.

@almcl did you upload the firmware before trying to configure? The new firmware will be needed.

@Smokie could you save your settings as a .conf file and attach it to a post?
Logged
Tom Carpenter (AstroEQ)

almcl

  • Full Member
  • ***
  • Posts: 26
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #39 on: February 09, 2017, 12:35:06 »

No, I didn't.

Just tried it a moment ago, uploading firmware from V7.5.  The upload failed and now neither version works, both report Read Failed.

Reloaded Version 7.4 and all worked again, so tried a further upload using the deebug version which worked this time, but the EPROM read failed again.
File attached,


« Last Edit: February 09, 2017, 12:50:57 by almcl »
Logged

Smokie

  • Full Member
  • ***
  • Posts: 39
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #40 on: February 09, 2017, 12:35:57 »

Hello Tom,

this is were i am

Gr,Henk
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 780
    • View Profile
    • AstroEQ
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #41 on: February 09, 2017, 12:46:47 »

No, I didn't.

Just tried it a moment ago, uploading firmware from V7.5.  The upload failed and now neither version works, both report Read Failed.

Unplug everything from the AstroEQ, then plug back in power followed by USB, then try uploading the firmware again.

Did it say why the upload failed? If you run the Debug version of the config utility you will get more details in a CMD window (like Smokie's screenshot).
Logged
Tom Carpenter (AstroEQ)

almcl

  • Full Member
  • ***
  • Posts: 26
    • View Profile
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #42 on: February 09, 2017, 12:52:44 »

Unplug everything from the AstroEQ, then plug back in power followed by USB, then try uploading the firmware again.

Did it say why the upload failed? If you run the Debug version of the config utility you will get more details in a CMD window (like Smokie's screenshot).

You're too quick for me , Tom  :)  I've just edited my post above to include the deebug text.
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 780
    • View Profile
    • AstroEQ
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #43 on: February 09, 2017, 16:01:11 »

You're too quick for me , Tom  :)  I've just edited my post above to include the deebug text.

Well the upload appears to have been a success. If you now try disconnecting the USB and reattaching it, and the click the Configure button from the main screen does it run the configuration?
Logged
Tom Carpenter (AstroEQ)

TCWORLD

  • Administrator
  • *****
  • Posts: 780
    • View Profile
    • AstroEQ
Re: [Completed] AstroEQ 8.0.3(beta)
« Reply #44 on: February 09, 2017, 16:56:37 »

Hello Tom,

this is were i am

Gr,Henk

Try again now. I've uploaded a new version to the original post.

I clearly wasn't exhaustive enough in testing the acceleration table generation routines. I've relaxed on of the calculation boundaries in the new version to help it converge better.

In the mean time I've got MATLAB running to try all possible IVal/bVal combinations. Will take about 3 hours!
« Last Edit: February 09, 2017, 16:59:37 by TCWORLD »
Logged
Tom Carpenter (AstroEQ)
Pages: 1 2 [3] 4 5 ... 10