Welcome, Guest. Please login or register.

Username: Password:

Author Topic: Problem with Dec axis Goto  (Read 69 times)

Sumukh P

  • Full Member
  • ***
  • Posts: 11
    • View Profile
Problem with Dec axis Goto
« on: April 30, 2020, 11:21:42 »

Hello,
I have made my own pcb for astroEQ with Mega2560 and DRV8825. I had some free time so tried my hands on goto for my mount. I have German EQ2 mount came with my telescope. I have fixed 2 Nema 17 steppers. I downloaded latest version of AstroEQ, Updated the firmware by setting correct gear ratios. I have 138:1 Worm ratio and there is steel spur gear to which I have attached another gear on RA motor giving the ratio of 5.38451638. I have 87:1 Worm ratio for DEC axis and to increase it further I have attached a 36 teeth GT2 pulley and another 20 teeth pulley on DEC motor making ratio of 1.8:1.
When I input these values in AstroEQ.exe, I could get proper numbers as per calculations of Ival, Aval, Bval.
Problem is after uploading and connecting with EQMOD, I am not able to slew it to correct DEC position. It is slewing almost 8 times more than required.

Here are the steps I am following,
I am using stellariumscope and latest version of Stellarium for control. In Stellariumscope I am selecting HEQ5/6 ASCOM. in Stellarium also I am selecting either ASCOM or local telescope through external software.
I tried manual slew using EQMOD using N S E W buttons. Still It is slewing at wrong point.
Any help woould be greatly appreciated.
« Last Edit: April 30, 2020, 11:25:26 by Sumukh P »
Logged

Sumukh P

  • Full Member
  • ***
  • Posts: 11
    • View Profile
Re: Problem with Dec axis Goto
« Reply #1 on: April 30, 2020, 11:26:03 »

Initially I thought I have problem with my driver but then I interchanged the drivers and checked again. There is same issue.
Logged

Sumukh P

  • Full Member
  • ***
  • Posts: 11
    • View Profile
Re: Problem with Dec axis Goto
« Reply #2 on: May 06, 2020, 15:32:25 »

Hello.
Problem solved.
I had to change the gear ratios in ASCOM HEQ5 settings. Previously it was set to auto, then I changed it to custom and gave RA/DEC worm steps and steps per rev.

Thanks Tom for such robust hardware.
Logged

TCWORLD

  • Administrator
  • *****
  • Posts: 751
    • View Profile
    • AstroEQ
Re: Problem with Dec axis Goto
« Reply #3 on: May 06, 2020, 16:12:23 »

Hi,

Apologies, I missed your question.

You shouldn't have to change anything in EQASCOM as the AstroEQ reports its information to EQMOD directly.

Could you send me your configuration from the config utility? (you can use the save button to save a .conf file, or take a screenshot).

A factor of 8 difference suggests an issue with the microstep mode selection - which would usually be due to a poor connection. Have you made the correct connections on SJ1 and SJ2? These are two jumpers in the middle of the AstroEQ PCB which need to be shorted depending on which driver you are using. For the DRV8825, you want to put a solder short or piece of wire to join the pins as indicated by the thick white line.
Logged
Tom Carpenter (AstroEQ)

Sumukh P

  • Full Member
  • ***
  • Posts: 11
    • View Profile
Re: Problem with Dec axis Goto
« Reply #4 on: May 08, 2020, 14:00:52 »

Hi Tom,
I am not using AstroEQ PCB. I have made my own Mega2560 version with only two motors, no other connectors.
Previously on myn old laptop, I was able to GoTo without any extra settings.
On my new laptop, I reinstalled everything now and the problem started. But I found the solution.
So, I am using stellariumscope. There I have to select mount. Which I selected HEQ5/6. In that properties, I set the coordinates of my location.
Again in mount settings option, I kept it to auto detect, and it took some random gear ratio and steps. Which was 8 times higher for DEC and 1.2 times higher for RA.
So in that place, I replaced the values obtained from config utility and it worked immediately.
I didn't remember doing this before in my old laptop.

Thanks,
Logged